I can't download the Crackle app. The store says it's not compatible with my device.

My friend, however, has a 3rd generation Kindle Fire HD 7, and has downloaded it.

What is going on here?