Register

Member Login

Welcome to the Kindle Fire Forum - Amazon Kindle Fire Forum.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

[ROOT][ONE-CLICK] How-To Get ADB running AND Root with SuperOneClick

This is a discussion on [ROOT][ONE-CLICK] How-To Get ADB running AND Root with SuperOneClick within the Amazon Kindle Fire Development forums, part of the Amazon Kindle Fire Hacking category; Found these instructions on PC World but haven't tried them yet so I can't attest to their effectiveness. How to Root Your Kindle Fire | ...

Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
Like Tree7Likes

Thread: [ROOT][ONE-CLICK] How-To Get ADB running AND Root with SuperOneClick

  1. #11
    Junior Member
    Member #
    249
    Join Date
    Oct 2011
    Location
    Arid Zona
    Posts
    5
    Found these instructions on PC World but haven't tried them yet so I can't attest to their effectiveness.

    How to Root Your Kindle Fire | PCWorld

  2. #12
    Junior Member
    Member #
    1738
    Join Date
    Feb 2012
    Location
    Kaiserslautern, Germany
    Posts
    2
    I followed the instructions to the letter as per the link above but my Kindle Fire is still not rooted. I'm at a loss.

    So when I selected ROOT in SuperOneClick v2.3.3.0, it went through the process but seem to hang up at Shell rooting device... -Step #7 Wait for device 0.04s

    I left it there, went away for a bit and came back and it had not changed.

    So, then I did some more research and found out that this doesn't work with update 6.2.1 or later (I have 6.2.2 now). However, I did find this link, which describes instruction for version 6.2.2:

    http://www.geek.com/articles/gadgets...fire-20111223/

    But yet again as I follow the step by step instructions... all is going well until I type: adb push su /system/xbin/su

    So then the Command Prompt tells me: cannot stat 'su': No such file or directory

    Stumped again <sigh>.

    Okay, then I went to here:

    http://rootkindlefire.com/kindle-fir...ndowsmaclinux/

    This was working great until I got to step 15. I typed at the Command Prompt: fastboot -i 01949 oem idme bootmode 4000

    Then I received reply: < waiting for device > with a flashing underscore... Now my PC can't find my KF device drivers! So I right-click and update drivers and manually select the folder with the android_winusb.ini file at it says: device drivers for your device not found.

    Now all I have on my screen is the yellow warning triangle with flame image and the words on the bottom that say: press power button for recovery. I assume it's TWRP Recovery but now my KF is locked. Nothing is working and now a grown man is about to cry...

    Someone please help me!

    <1 hour later> So, I rebooted my PC and plugged my USB canle back into my KF. At least the device manager recognized it as a Kindle and not an unknown device now. So, I right-clicked and selected update drivers. Instead of manually browsing, I selected to locate from a previous location. Then made it to the Andriod ADB Interface and selected it. Command Prompt finished after I typed fastboot reboot. And presto! My KF is now rooted! So I am now happy that my KF is not bricked and rooted.

    FYI, from start to finish was 3 hours (12:30am-3:30am). Now I can go to sleep a happy man!
    Last edited by Robman; 02-03-2012 at 08:33 PM.
    Robert "Robman" Manore
    Kindle Fire Owner since 12/2011

 

 
Page 2 of 2 FirstFirst 12

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. #Got Root?
    By jblalock77 in forum Kindle-FireForum.com Root & Honeycomb/ICS Bounty
    Replies: 10
    Last Post: 12-18-2015, 12:03 AM
  2. Kindle-FireForum.com Root & Honeycomb/ICS Bounty!
    By jblalock77 in forum Amazon Kindle Fire News
    Replies: 6
    Last Post: 10-20-2011, 08:08 AM

Search tags for this page

shell rooting device step #7

,

shell rooting device step 7

,
superoneclick shell rooting device step #7
,
superoneclick step 7
,
superoneclick step 7 waiting for device
,

superoneclick v2.3.3.0

,
superoneclick waiting for device step 7
Click on a term to search for related topics.
Back to Top